How to Install Ruby 1.9.2 and Rails 3.0 on Ubuntu 10.10

01/01/2011 — Leave a comment

If you are newbie on linux you might run into the same problem I had. I tried to install ruby and then ruby on rails by compiling source code of ruby and then just try gem install rails. Everything worked until I tried that command. I was getting that awful “no such file to load — zlib” error – hey I’m still newbie i have no idea what that is! :)

So many hours later I found solution, both as a wall of text and as a screen cast!

So after all that compiling I tried installing and following bunch of articles which led up to a point that i had to(only in my head) re-install Ubuntu… :) So that’s what i did!

With fresh Ubuntu 10.10 installed I went straight back to page which was given to me in #rubyonrails irc channel by some random(for me) cool dude. In comments I found a link to a screen cast of the same thing, so enjoy:

  1. Wall of text version – http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you
  2. Screen cast version – http://www.rubyinside.com/how-to-install-ruby-1-9-2-and-rails-3-0-on-ubuntu-10-10-4148.html

I ended up following screen cast version and it worked!

Big thanks and love for both of those articles! <3

Miloš Gavrilović

Posts Twitter

Freelance web developer.